[SOLVED] test upgrade to 6.4.3 - perl error

Moderator: crythias

Post Reply
lis9
Znuny newbie
Posts: 22
Joined: 13 Apr 2017, 11:27
Znuny / OTRS Version: 6.0.40
Real Name: Daniel
Company: Komputronik S.A.

[SOLVED] test upgrade to 6.4.3 - perl error

Post by lis9 »

I've installed new Znuny feature version 6.4.3 on my testing instance. It is sometimes unstable. I've got some perl errors:

[Thu Sep 22 14:19:11.502455 2022] [perl:error] [pid 73339] [client 172.23.0.233:65030] Use of each() on hash after insertion without resetting hash iterator results in undefined behavior, Perl interpreter: 0x5585d5d1e880 at /opt/otrs/Kernel/cpan-lib/Apache2/Reload.pm line 171.\n, referer: http://10.21.32.167/otrs/index.pl?Actio ... ID=7570854

causing 500 server error. Is this bug or something went wrong during my installation?

Best regards.
Daniel
Last edited by lis9 on 23 Sep 2022, 12:03, edited 1 time in total.
root
Administrator
Posts: 3370
Joined: 18 Dec 2007, 12:23
Znuny / OTRS Version: Znuny and Znuny LTS
Real Name: Roy Kaldung
Company: Znuny
Contact:

Re: test upgrade to 6.4.3 - perl error

Post by root »

Hi,

Which Linux distribution do you use?

- Roy
Znuny and Znuny LTS running on CentOS / RHEL / Debian / SLES / MySQL / PostgreSQL / Oracle / OpenLDAP / Active Directory / SSO

Use a test system - always.

Do you need professional services? Check out https://www.znuny.com/

Do you want to contribute or want to know where it goes ?
lis9
Znuny newbie
Posts: 22
Joined: 13 Apr 2017, 11:27
Znuny / OTRS Version: 6.0.40
Real Name: Daniel
Company: Komputronik S.A.

Re: test upgrade to 6.4.3 - perl error

Post by lis9 »

RockyLinux 8.6, MariaDB 10.4.8
perl 5, version 26, subversion 3 (v5.26.3)

o Apache::DBI......................ok (v1.12)
o Apache2::Reload..................ok (v0.13)
o Archive::Tar.....................ok (v2.40)
o Archive::Zip.....................ok (v1.68)
o Authen::SASL.....................ok (v2.16)
o Crypt::Eksblowfish::Bcrypt.......ok (v0.009)
o Crypt::JWT.......................ok (v0.034)
o Crypt::OpenSSL::X509.............ok (v1.914)
o CSS::Minifier::XS................ok (v0.13)
o Data::UUID.......................ok (v1.226)
o Date::Format.....................ok (v2.24)
o DateTime.........................ok (v1.58)
o DateTime::TimeZone.............ok (v2.47)
o DBI..............................ok (v1.643)
o DBD::mysql.......................ok (v4.046)
o DBD::ODBC........................Not installed! To install, you can use: 'cpan DBD::ODBC'. (optional - Required to connect to a MS-SQL database.)
o DBD::Oracle......................Not installed! To install, you can use: 'cpan DBD::Oracle'. (optional - Required to connect to a Oracle database.)
o DBD::Pg..........................Not installed! To install, you can use: 'cpan DBD::Pg'. (optional - Required to connect to a PostgreSQL database.)
o Digest::SHA......................ok (v6.03)
o Encode::HanExtra.................ok (v0.23)
o Excel::Writer::XLSX..............ok (v0.95)
o Hash::Merge......................ok (v0.302)
o IO::Socket::SSL..................ok (v2.074)
o JavaScript::Minifier::XS.........ok (v0.15)
o Jq...............................ok (v0.01)
o JSON::XS.........................ok (v4.03)
o List::Util::XS...................ok (v1.63)
o LWP::UserAgent...................ok (v6.53)
o Mail::IMAPClient.................ok (v3.43)
o IO::Socket::SSL................ok (v2.074)
o Authen::NTLM...................ok (v1.09)
o ModPerl::Util....................ok (v2.000012)
o Moo..............................ok (v2.005004)
o Net::DNS.........................ok (v1.34)
o Net::LDAP........................ok (v0.68)
o Net::LDAP::Constant..............ok (v0.24)
o Net::SMTP........................ok (v3.14)
o Spreadsheet::XLSX................ok (v0.17)
o Template.........................ok (v3.100)
o Template::Stash::XS..............ok (undef)
o Text::Diff::FormattedHTML........ok (v0.08)
o Text::CSV_XS.....................ok (v1.48)
o Time::HiRes......................ok (v1.9764)
o XML::LibXML......................ok (v2.0207)
o XML::LibXSLT.....................ok (v1.96)
o XML::Parser......................ok (v2.44)
o YAML::XS.........................ok (v0.85)

Bundled modules:

o Algorithm::Diff..................ok (v1.1903)
o Apache::DBI......................ok (v1.12)
o CGI..............................ok (v4.36)
o CSS::Minifier....................ok (v0.01)
o Class::Inspector.................ok (v1.31)
o Crypt::PasswdMD5.................ok (v1.40)
o Crypt::Random::Source............ok (v0.14)
o Email::Valid.....................ok (v1.202)
o Encode::Locale...................ok (v1.05)
o Exporter::Tiny...................ok (v1.002001)
o IO::Interactive..................ok (v1.022)
o JSON.............................ok (v2.94)
o JSON::PP.........................ok (v2.27203)
o JavaScript::Minifier.............ok (v1.15)
o LWP..............................ok (v6.53)
o Linux::Distribution..............ok (v0.23)
o Locale::Codes....................ok (v3.52)
o MIME::Tools......................ok (v5.509)
o Mail::Address....................ok (v2.18)
o Mail::Internet...................ok (v2.18)
o Math::Random::ISAAC..............ok (v1.004)
o Math::Random::Secure.............ok (v0.080001)
o Module::Find.....................ok (v0.15)
o Module::Refresh..................ok (v0.17)
o Moo..............................ok (v2.005004)
o Mozilla::CA......................ok (v20211001)
o Net::HTTP........................ok (v6.17)
o Net::IMAP::Simple................ok (v1.2209)
o Net::SSLGlue.....................ok (v1.058)
o PDF::API2........................ok (v2.033)
o SOAP::Lite.......................ok (v1.20)
o Sisimai..........................ok (vv4.25.11)
o Sys::Hostname::Long..............ok (v1.5)
o Text::CSV........................ok (v1.95)
o Text::Diff.......................ok (v1.44)
o Types::TypeTiny..................ok (v1.010000)
o URI..............................ok (v1.71)
o YAML.............................ok (v1.23)
o namespace::clean.................ok (v0.27)
o parent...........................ok (v0.236)
Last edited by lis9 on 22 Sep 2022, 17:56, edited 1 time in total.
lis9
Znuny newbie
Posts: 22
Joined: 13 Apr 2017, 11:27
Znuny / OTRS Version: 6.0.40
Real Name: Daniel
Company: Komputronik S.A.

Re: test upgrade to 6.4.3 - perl error

Post by lis9 »

additionally in system log I have found some errors:

Cannot add or update a child row: a foreign key constraint fails (`otrs_test`.`ticket_flag`, CONSTRAINT `FK_ticket_flag_ticket_id_id` FOREIGN KEY (`ticket_id`) REFERENCES `ticket` (`id`)), SQL: '
root
Administrator
Posts: 3370
Joined: 18 Dec 2007, 12:23
Znuny / OTRS Version: Znuny and Znuny LTS
Real Name: Roy Kaldung
Company: Znuny
Contact:

Re: test upgrade to 6.4.3 - perl error

Post by root »

lis9 wrote: 22 Sep 2022, 17:23 RockyLinux 8.6, MariaDB 10.4.8
perl 5, version 26, subversion 3 (v5.26.3)
Hi,

Which MPM-module is enabled? This can be found in /etc/httpd/conf.modules.d/00-mpm.conf

- Roy
Znuny and Znuny LTS running on CentOS / RHEL / Debian / SLES / MySQL / PostgreSQL / Oracle / OpenLDAP / Active Directory / SSO

Use a test system - always.

Do you need professional services? Check out https://www.znuny.com/

Do you want to contribute or want to know where it goes ?
lis9
Znuny newbie
Posts: 22
Joined: 13 Apr 2017, 11:27
Znuny / OTRS Version: 6.0.40
Real Name: Daniel
Company: Komputronik S.A.

Re: test upgrade to 6.4.3 - perl error

Post by lis9 »

in this file I have this module uncommented:

LoadModule mpm_prefork_module modules/mod_mpm_prefork.so
root
Administrator
Posts: 3370
Joined: 18 Dec 2007, 12:23
Znuny / OTRS Version: Znuny and Znuny LTS
Real Name: Roy Kaldung
Company: Znuny
Contact:

Re: test upgrade to 6.4.3 - perl error

Post by root »

lis9 wrote: 22 Sep 2022, 14:38
[Thu Sep 22 14:19:11.502455 2022] [perl:error] [pid 73339] [client 172.23.0.233:65030] Use of each() on hash after insertion without resetting hash iterator results in undefined behavior, Perl interpreter: 0x5585d5d1e880 at /opt/otrs/Kernel/cpan-lib/Apache2/Reload.pm line 171.\n, referer: http://10.21.32.167/otrs/index.pl?Actio ... ID=7570854

causing 500 server error. Is this bug or something went wrong during my installation?
Have you installed any add-ons via the package manager after the installation?

- Roy
Znuny and Znuny LTS running on CentOS / RHEL / Debian / SLES / MySQL / PostgreSQL / Oracle / OpenLDAP / Active Directory / SSO

Use a test system - always.

Do you need professional services? Check out https://www.znuny.com/

Do you want to contribute or want to know where it goes ?
lis9
Znuny newbie
Posts: 22
Joined: 13 Apr 2017, 11:27
Znuny / OTRS Version: 6.0.40
Real Name: Daniel
Company: Komputronik S.A.

Re: test upgrade to 6.4.3 - perl error

Post by lis9 »

Yes, but there were just upgrades from previous versions:

FAQ
GeneralCatalog
ImportExport
ITSM
ITSMChangeManagement
ITSMConfigurationManagement
ITSMCore
ITSMIncidentProblemManagement
ITSMServiceLevelManagement
CloneDB
MasterSlave
Survey

Znuny:
Autoselect
DownloadAllAttachments
EscalationSuspend
ITSMConfigItemInvoker
QuickClose
ShowTicketUnlockTime
SortByLastContact
root
Administrator
Posts: 3370
Joined: 18 Dec 2007, 12:23
Znuny / OTRS Version: Znuny and Znuny LTS
Real Name: Roy Kaldung
Company: Znuny
Contact:

Re: test upgrade to 6.4.3 - perl error

Post by root »

Hi,

Have you restarted the web server after installing/upgrading the add-ons?
Some of them are replacing existing files, others use the Autoload() mechanism, or the Custom/ folder. That's why a restart of the webserver is recommended.

- Roy
Znuny and Znuny LTS running on CentOS / RHEL / Debian / SLES / MySQL / PostgreSQL / Oracle / OpenLDAP / Active Directory / SSO

Use a test system - always.

Do you need professional services? Check out https://www.znuny.com/

Do you want to contribute or want to know where it goes ?
lis9
Znuny newbie
Posts: 22
Joined: 13 Apr 2017, 11:27
Znuny / OTRS Version: 6.0.40
Real Name: Daniel
Company: Komputronik S.A.

Re: test upgrade to 6.4.3 - perl error

Post by lis9 »

Ofcourse i did :D many times :D
Now my plan is to uninstall all packages and just in this moment i've got problem with uninstalling ITSM-6.4.2. It just wouldn't uninstall! I will try to do it manually.

DL
lis9
Znuny newbie
Posts: 22
Joined: 13 Apr 2017, 11:27
Znuny / OTRS Version: 6.0.40
Real Name: Daniel
Company: Komputronik S.A.

Re: test upgrade to 6.4.3 - perl error

Post by lis9 »

Roy, Thank you very much for your assistance.

I think that reinstalling ITSM from scratch solved the problem.
My opinion is that something went wrong on stage of migration 6.2 to 6.3, when repository configuration changes.
I will now test the other scenario and migrate thru 6.3.1 and 6.3.4 step by step.

My goal is to migrate from 6.0.40 to 6.4.3 :D

DL
Post Reply